Subject: [OKAIRP] CIRP Freshman Survey

From: "Stewart, Sheilynda" <[email-masked]>
Date: Fri, 21 May 2010 09:27:28 -0500

All,

    I was wondering if any of you have administered the Cooperative
Institutional Research Program (CIRP) freshmen survey at your
institution?  If so, what are your thoughts about this particular
instrument?

Thank you for your comments!

Sheilynda Stewart  

Sheilynda Stewart, Ph.D.

Director of Institutional Research

East Central University

1100 E. 14th Street

Ada, Oklahoma  74820-6999

Phone:  580-559-5668

email:  [email-masked] <mailto:[email-masked]>  

 

Confidentiality Notice: This e-mail message, including any attachments,
is for the sole use of the intended recipient(s) and may contain
confidential and privileged information. Any unauthorized review, use,
disclosure or distribution is prohibited. If you are not the intended
recipient, please contact the sender by reply e-mail and destroy all
copies of the original message.

---

From: "Cal Easterling" <[email-masked]>
Date: Fri, 21 May 2010 14:33:56 -0500

Dr. Stewart,

We do use this survey, as well as Your First College Year, the College Senior Survey, NSSE, and the Student Satisfaction Survey. We have used the CIRP for quite some time, though not every year. The CIRP Freshman Survey collects data regarding student demographics, parents’ demographics, student self-rated abilities, interests, opinions, activities, academic experience, future major, career goals, and educational financing.There will be a HERI users' group at AIR in Chicago. We are planning to administer it to incoming first-year students during "Harbor" (our freshman orientation event) in August. We  also did it in 2006, 2002, and all the way back to 1974.

In the past, we have found out such helpful information as: 

87.2% stated that ORU was their first choice. The top three reasons they gave for attending ORU were: (1) financial assistance at ORU, (2) ORU graduates get good jobs, and (3) ORU’s good academic reputation. The ORU freshmen surveyed tended to expend less time studying and more time surfing the net than the national average. They also tended to value to a greater extent than the national average such items as finding their purpose, being honest in relationships, and believing in the sacredness of life. More of the ORU freshmen rated themselves "above average" in intellectual and social confidence, self-understanding, and spirituality than the national average. They rated themselves lower than the national average in artistic and computer skills.

It can be an important part of your continuous improvement program IF you intentionally endeavor to identify areas of challenge, implement real actions plans to address them, and them follow up by holding individuals responsible.

Have a happy day

Cal Easterling, Ph.D.
Institutional Research
Oral Roberts University
(918)495-6538
http://ir.oru.edu
http://ePortfolio.oru.edu
[email-masked]
!
>>> "Stewart, Sheilynda" <[email-masked]> 5/21/2010 9:27 AM >>>
 
All,
 
    I was wondering if any of you have administered the Cooperative Institutional Research Program (CIRP) freshmen survey at your institution?  If so, what are your thoughts about this particular instrument?

 
Sheilynda Stewart  
Sheilynda Stewart, Ph.D.
email:  [email-masked] 

 
 
Confidentiality Notice: This email message, including any attachments, is for the sole use of the intended recipient(s) and may contain confidential and privileged information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply email and destroy all copies of the original message.