Subject: [OKAIR] Question about Exit, Alumni, and Employer Surveys

From: [email-masked]
Date: Fri, 17 Feb 2012 13:25:22 -0600

Hello everyone,

At TCC, we are revisiting our processes for conducting our Exit, Alumni,
and Employer Surveys (we do not have an Alumni Office). Can you share some
answers to the questions below?

1) Do you conduct an Exit Survey or Interview for your graduates? If so,
how and when are the surveys administered, completed, and collected?

2) Do you conduct an Alumni Survey for your graduates? If so, how and when
are the surveys administered, completed, and collected?

3) Do you conduct an Employer Survey for your alumni? If so, how do you get
the employer information?  Also, how and when are the surveys administered,
completed, and collected?

Thanks for any ideas you can share!

Kevin

--
Kevin M. David, Ph.D.
Director, Planning and Institutional Research
Tulsa Community College
6111 E. Skelly Drive, Room 408
Tulsa, OK 74135-6198
Phone: (918) 595-7925
Fax: (918) 595-7988
E-mail: [email-masked]

---

From: Karla Oty <[email-masked]>
Date: Tue, 21 Feb 2012 12:35:04 +0000

Kevin,

At Cameron University, the individual departments are responsible for conducting exit surveys and alumni surveys.  Each department has different means of administering and collecting the surveys.

We currently are not conducting Employer Surveys, per se.  We get most of our information from Employers through our various Advisory Boards/Councils.

Karla

Karla J. Oty, Ph.D.
Director of Institutional Research, Assessment, and Accountability
Cameron University
2800 W. Gore Blvd.
Lawton, OK 73505
(580) 581-2899
[email-masked]<mailto:[email-masked]>
________________________________
From: [email-masked] [[email-masked]] on behalf of [email-masked] [[email-masked]]
Sent: Friday, February 17, 2012 1:25 PM
To: [email-masked]
Subject: [OKAIR] Question about Exit, Alumni, and Employer Surveys

Hello everyone,

At TCC, we are revisiting our processes for conducting our Exit, Alumni, and Employer Surveys (we do not have an Alumni Office). Can you share some answers to the questions below?

1) Do you conduct an Exit Survey or Interview for your graduates? If so, how and when are the surveys administered, completed, and collected?

2) Do you conduct an Alumni Survey for your graduates? If so, how and when are the surveys administered, completed, and collected?

3) Do you conduct an Employer Survey for your alumni? If so, how do you get the employer information? Also, how and when are the surveys administered, completed, and collected?

Kevin